TWQ_View
версия 1.2
© Дмитрий В. Доливо-Добровольский, 2006-2016
ИГГД РАН, наб. Макарова, 2, Санкт-Петербург 199034, Россия

E-mail: ddd@ipgg.ru


Назначение и основные свойства программы

 TWQ_View – это удобная и бесплатная Windows-программа для просмотра и базовой работы с диаграммами, рассчитанными в известной программе для геотермобарометрических исследований ©TWQ Р.Бермана, Т.Брауна, Э.Перкинса и Дж.Эллвуда (Berman, 1991).

С помощью TWQ_View Вы можете:

  • отображать TWQ-диаграммы на экране;
  • изменять их внешний вид;
  • отмечать кривые разными цветами и находить определённые равновесия как щелчками по кривым, так и выбором их в списке;
  • менять масштаб диаграмм;
  • перемещаться по диаграммам;
  • показывать/скрывать выбранные кривые и наборы кривых, содержащих выбранные компоненты;
  • объединять диаграммы;
  • быстро выбирать и отображать диаграммы, находящиеся в одном каталоге (из их списка);
  • графически отображать составы фаз (мольные доли компонентов/элементов) для списка CMP-файлов;
  • запускать программу INTERSX.EXE для отдельных или сразу для всех диаграмм, находящихся в одном каталоге (с помощью циклических перезапусков этой программы, работающей в пакетном режиме). Благодаря встроенной поддержке эмулятора DOSBox 16-битная DOS-версия программы может работать и в 64-битной операционной системе (Windows Vista, 7 и 8);
  • отображать вычисленные средние значения (с их среднеквадратическими отклонениями) на диаграммах вместе с кривыми равновесий;
  • искать диаграммы с наилучшим схождением пересечений с помощью сортировки таблицы средних значений;
  • менять единицы давления (бар→кбар) и активностей (Log(α)→α);
  • автоматически заменять аббревиатуры минералов на предпочитаемые (находящиеся в редактируемом списке замен);
  • копировать диаграммы в буфер обмена Windows в векторном виде (в формате графического метафайла, WMF) для последующей вставки в другие программы (например, в ©CorelDraw или ©MS Word).

 С программой TWQ_View можно ассоциировать расширения файлов диаграмм (например *.PLT, *.P1) и просматривать диаграммы простыми щелчками по именам их файлов в файловом менеджере.

 TWQ_View написана в среде ©Borland Delphi 7 и основана на компоненте ©TeeChart (стандартная версия 4.04 от Д. Бернеды, Steema software).

Обратно к Оглавлению


Требования и установка

 TWQ_View работает под управлением ОС ©MS Windows. В настоящее время программа разрабатывается в версии XP, хотя она должна также работать как в более ранних, так и в более поздних версиях Windows. Достаточно важным (но не критическим) оказывается использование экрана с высоким разрешением, т.к. программа выводит много информации в нескольких окнах одновременно.

 Несмотря на то, что TWQ_View ориентирована на работу со старой DOS-версией программы INTERSX.EXE комплекса TWQ, программу также можно использовать и в сочетании с её Windows-версией winTERSX.EXE – однако, запускаемой отдельно. Но, к сожалению, как ранние, так и особенно последние версии winTERSX.EXE неудовлетворительно работают в пакетном режиме вычислений. TWQ_View позволяет работать со старой 16-битной INTERSX.EXE и под управлением 64-битных версий ОС (например, Windows Vista, 7 и 8) за счёт встроенной поддержки эмулятора DOSBox (последний необходимо скачать и установить самостоятельно). Однако, использование эмулятора для DOS-версии TWQ может оказаться привлекательным и при работе в 32-битных версиях Windows, за счёт снятия 19-символьного ограничения на длину путей к программам TWQ и к файлам данных (кроме того, можно использовать длинные имена каталогов). NB! Однако, у DOSBox есть и ограничение: при его использовании каталог с рабочими файлами не должен быть вложен в каталог с программами TWQ (и наоборот)!

 Хотя эмулятор DOSBox специально предназначен для запуска старых игр в новых операционных системах и на новом оборудовании, а его авторы в настоящее время решительно отказываются от какой-либо поддержки неигровых приложений (см. http://www.vogons.org/viewtopic.php?t=27920), он обладает следующими важными преимуществами:

  • является свободно распространяемой программой с открытым кодом (универсальная общественная лицензия GNU);
  • обладает небольшим размером;
  • весьма прост в установке и использовании;
  • работает без особых нареканий;
  • быстро загружается;
  • является переносимым (portable) приложением, т.е. каталог с эмулятором можно просто скопировать на съёмное устройство (например, на "флешку") и работать с него. Как TWQ_View, так и пакет TWQ также могут работать со съёмных устройств (при этом TWQ_View старается корректно заменять букву текущего диска в путях к программам).
 Для установки программы просто распакуйте все файлы из zip-архива в требуемый каталог. В архиве находятся следующие файлы:
  • TWQ_VIEW.EXE – исполняемый файл программы;
  • TWQ_VIEW.INI – файл с сохранёнными параметрами (программа создаёт новый файл, если он отсутствует);
  • TWQ_VIEW.RPL – текстовый файл с редактируемым спсиком замен для аббревиатур минералов;
  • TWQ_VIEW.CHM – файл со справкой по программе (документация), английская версия;
  • TWQ_VIEW_RUS.CHM – файл со справкой по программе (документация), русская версия;
  • ALS.PLT – весьма полезная P-T диаграмма Ky-Sil-And (для хранилища диаграмм-шаблонов, Вы можете использовать для него как каталог TWQ_View, так и любой другой каталог);
  • QTZ.PLT – другая полезная P-T диаграмма αQtz-βQtz для хранилища;
  • 001.P1 – пример P-T диаграммы (NB! С хорошим пучком для безгранатового парагенезиса!);
  • 002.P1 – пример диаграммы P-Log α(H2O).

 После распаковки требуется немного отредактировать файл TWQ_View.ini. По крайней мере, следует определить корректные значения для следующих переменных:

  • TWQDir= путь к файлам DOS-версии пакета TWQ;
  • DOSBox= путь к исполняемому файлу DOSBox.exe (если эмулятор был установлен);

 TWQ_View ничего не пишет в системные файлы, в т.ч. в реестр Windows. Поэтому её деинсталляция заключается в простом удалении каталога программы со всем содержимым. Однако, Вы можете вручную ассоциировать с нею типы файлов диаграмм TWQ (например, *.PLT и *.P1) для просмотра диаграмм простыми щелчками по именам их файлов в файловом менеджере.


Работа с TWQ_View

 Программа может быть запущена с параметром командной строки – именем файла с диаграммой TWQ (с расширением). Это свойство позволяет ассоциировать TWQ_View с расширениями этих файлов, т.е. использовать программу в качестве их вьюера. Если TWQ_View запускается без параметров, то надо сначала выбрать файл диаграммы из стандартного системного диалогового окна "Open". Программа запоминает путь к последнему загруженному файлу как путь по умолчанию для следующего запуска.
 TWQ_View работает в пяти независимых окнах. Вы можете показывать, скрывать и изменять их размеры и расположение, при этом программа запоминает эти параметры для последующих запусков.

Меню (главное окно)
Диаграмма (главное окно)
Установки программы (окно Options)
Списки равновесий и компонентов (окно Equilibria)
Список диаграмм (окно Plot-files)
Диаграмма составов (окно CMP-files)
Файл с заменами аббревиатур (TWQ_VIEW.RPL)
Работа с INTERSX.EXE и средними значениями
Переменные инициализационного файла (TWQ_VIEW.INI)


Меню (главное окно)

 Меню главного окна TWQ_View содержит четыре основных раздела (их горячие клавиши подчёркнуты):

File
 Базовые файловые операции. Пункты подменю:

Load – очистка диаграммы и загрузка нового файла с помощью стандартного диалогового окна Windows "Open". Этот способ позволяет сменить каталог, используемый по умолчанию для файлов диаграмм в TWQ-View. Текущий путь отображается в заголовке главного окна программы.

Combine – загрузить новый файл диаграммы с помощью стандартного диалогового окна Windows "Open", скомбинировав его с уже построенной текущей диаграммой. Программа производит простейшую проверку совместимости диаграмм (по названиям осей) и подгоняет границы, если это требуется. Этот метод также изменяет каталог файлов с диаграммами по умолчанию.

Repository – загрузить файл из специального каталога-хранилища шаблонных диаграмм (библиотеки полезных и часто используемых равновесий, используемых в качестве визуальных реперов) и отобразить его кривые поверх существующих данных. В отличие от предыдущего метода, границы остаются неизменными. Простая структура текстовых файлов с диаграммами TWQ позволяет создавать такие шаблоны вручную (с любыми кривыми, а не только вычисленными в TWQ). Загрузка файла из другого места изменяет путь к каталогу-хранилищу.

Exit – завершение программы.

Программа показывает список последних рабочих каталогов (до 30) в нижней части подменю File. Вы можете их выбирать для загрузки/добавления/просмотра диаграмм из этих часто используемых мест. Этот список можно очистить вручную, удалив все строчки, начинающиеся с PlotPath= из файла TWQ_View.ini.

Windows
 Показать/активировать другие 4 окна программы:

Options – настройки программы;

Equilibria – списки равновесий и компонентов системы;

Plot-files – список файлов с диаграммами в текущем каталоге (для их быстрой загрузки), информационная панель и список расширений.

CMP-files – графики составов минералов, построенные по всем CMP-файлам текущего каталога (т.е. для всех соответствующих им файлов диаграмм).

 Программа использует именованные наборы параметров окон (их расположение и размеры): так называемые Desktops (рабочие столы). Они показываются в нижней части подменю Windows. Нажмите на один из этих пунктов для быстрой перегруппировки окон программы, либо выберите последний пункт (<Save desktop>) для сохранения текущего набора параметров. Введите название для нового набора, либо наберите в поле ввода слово Default (или очистите его) для дальнейшего использования текущих параметров по умолчанию.

Analysis
 TWQ_View может помочь с анализом пересечений линий равновесий, если есть пары файлов диаграмма + составы. Она запускает программу INTERSX.EXE (входящую в состав DOS-версии пакета TWQ) и извлекает средние значения из выходных файлов последней.

 Конечно же, нет необходимости проводить этот анализ каждый раз, когда Вы запускаете TWQ_View для одного и того же набора файлов с диаграммами. Программа загружает результаты вычислений из своих файлов автоматически при смене каталога и сразу же показывает уже имеющиеся средние значения на диаграммах.

INTERSX.EXE – запустить программу INTERSX.EXE с параметрами, указанными в следующем пункте подменю.

Database: <имя файла или "?"> – открыть небольшое диалоговое окно для задания параметров программы INTERSX.EXE. Нажмите кнопку Add для добавления базы термодинамических данных в список (например, ba96.dat). Программа использует путь к файлам БД в качестве параметра каталог TWQ. Нажмите кнопку Delete для удаления выделенного файла из списка. Кнопка Solutions служит для привязки соответствующего SLN-файла (с описаниями растворов) с выделенной БД. Этот файл также требуется для работы программы INTERSX.EXE. Нажмите кнопку Select (либо произведите двойной щелчок по имени БД в списке) для выбора БД в качестве текущей: её имя заменит вопросительный знак "?" в меню. Отметьте галочкой опцию Paused run для того, чтобы после завершения работы программы INTERSX.EXE DOS-окно осталось открытым. Эта опция иногда помогает определить, почему INTERSX.EXE не хочет работать должным образом. Поставьте галочку Batch run для обработки всего набора сходных диаграмм в пакетном режиме (NB! Программа снимает эту галочку после завершения операции).

 Если открыто окно с таблицей результатов (см. ниже), то TWQ_View запустит обработку только тех файлов, которые отмечены там галочками.

 Если какие-то линии равновесий не показываются, то при использовании программы INTERSX.EXE средние параметры будут вычисляться только с учётом отображаемых линий. Это удобно для исключения линий, слишком сильно меняющих своё положение при совсем незначительных вариациях составов минералов.

 Галочка DOSBox служит для указания, что 16-битную DOS версию программы INTERSX.EXE следует запускать с помощью эмулятора DOS. Если эмулятор не установлен и/или в инициализационном файле TWQ_View.ini не указан путь к файлу DOSBox.exe, то опция всегда недоступна и галочка там отсутствует. Если эмулятор установлен, путь к нему указан, а ОС, в которой Вы работаете, является 64-битной (Windows Vista, 7 или 8), то галочка стоит, но снять её нельзя. В случае 32-битной ОС (например, Windows XP) галочку можно устанавливать и снимать самостоятельно.

 TWQ_View использует довольно сложную стратегию для запусков INTERSX.EXE в пакетном режиме. Она пытается гарантировать, что все Ваши файлы с диаграммами будут обработаны вне зависимости от того, что некоторые из них будут вызывать аварийное завершение INTERSX.EXE (что, к сожалению, случается очень часто):

  1. Замена ссылок на файлы БД и её SLN-файл в конфигурационном файле TWQ PTAXCON.FIG;
  2. Создание файла BATCH.DAT в каталоге TWQ и запись в него:
    1. имени каталога с файлами диаграмм (NB! Помните, что в DOS-версии пакета TWQ этот путь не должен превышать 20 символов, включая завершающую обратную косую черту "\"!),
    2. имени файла перезапуска (всегда RESTART.RES),
    3. имён файлов БД для компонентов твёрдых фаз и флюида, а также для водных частиц HKF'81 (последняя берётся из файла PTAXCON.FIG),
    4. имени файла со списком файлов составов (всегда CMP.DAT);
  3. Запись списка существующих файлов составов в CMP.DAT в каталоге с диаграммами;
  4. Создание пакетного файла INTRSX.BAT в каталоге TWQ и запись в него команд DOS:

    @echo off
    cd TWQ_directory
    INTERSX.EXE /B < INTERSX.ASK

    где INTERSX.ASK является файлом перенаправления клавиатурного ввода;
  5. Создание файла INTERSX.ASK в каталоге TWQ. Он содержит всего 3 символа <CR> (т.е. 3 нажатия на клавишу <Enter>);
  6. Создание файла TEMP.AVG в каталоге с диаграммами (программа в него складывает полученные результаты);
  7. Запуск INTRSX.BAT и ожидание его завершения;
  8. Чтение CMP.AVG и добавление проанализированных записей из него в файл TEMP.AVG. В CMP.AVG программа ищет:
    1. средние значения,
    2. имя последнего обработанного файла;
  9. Если обработаны все файлы, то переход на пункт 12;
  10. Обновление файла CMP.DAT: там остаются только необработанные файлы составов;
  11. Возврат к пункту 7;
  12. Удаление файлов: CMP.AVG, CMP.DAT, INTERSX.ASK, INTRSX.BAT и Averages.dat (см. ниже);
  13. Переименование TEMP.AVG в CMP.AVG;
  14. Анализ CMP.AVG и всех существующих отдельных AVG-файлов, отсутствующих в CMP.AVG;
  15. Выход.

 Если некоторые из файлов диаграмм оказываются необработанными (например, вследствие критических ошибок в программе INTERSX.EXE), или если файл CMP.AVG вообще не создаётся, то тогда TWQ_View ищет отдельные AVG-файлы в каталоге с диаграммами и заполняет пропуски. Я обнаружил, что INTERSX.EXE хорошо обрабатывает некоторые отдельные файлы диаграмм, но аварийно завершается на этих же файлах при работе в пакетном режиме.

 Иногда перманентные аварийные завершения программы INTERSX.EXE приводят к зацикливанию процесса при работе в пакетном режиме, при котором снова и снова производятся неудачные попытки обработки одного и того же файла. Для выхода из этого бесконечного цикла предусмотрена кнопка с красным кружком, появляющаяся в правом нижнем углу окна с диаграммой на время пакетной обработки. Реакция на нажатие этой кнопки не является немедленной: вопрос о завершении задаётся только после закрытия очередного DOS-окна программы INTERSX.EXE.

 Получающийся в итоге файл CMP.AVG (вместе с остальными AVG-файлами) занимает очень большой объём: для TWQ_View может потребоваться довольно много времени, чтобы их проанализировать. Поэтому программа записывает специальный относительно небольшой текстовый файл Averages.dat (с главными результатами, извлечёнными из AVG-файлов) при первичной обработке файлов CMP.AVG + *.AVG и загружает только этот файл при последующих запусках для данного рабочего каталога. Если файл Averages.dat удалить, то программа повторит анализ всех существующих AVG-файлов. При наличии файла Averages.dat все AVG-файлы можно либо удалить совсем, либо сжать в архив (например, с помощью метода ZIP) для освобождения дискового пространства. Если в каталоге есть AVG-файлы для отдельных диаграмм, то их данные имеют преимущество перед данными из Averages.dat.

Table of averages – создать и отобразить таблицу вычисленных средних значений для всех обработанных диаграмм. Можно выбрать один из трёх типов средних значений:

  1. All – средние значения, основанные на всех парных пересечениях линий,
  2. 1.5 sigma – средние значения, основанные на пересечениях, лежащих в пределах 1.5 величины среднеквадратического отклонения,
  3. IR – средние значения, основанные на некотором(?) наборе линейно независимых равновесий.

 Таблица состоит из 12 колонок:

  1. Имена файлов (Files);
  2. Количества использованных пересечений (Used);
  3. X – значения по горизонтальной оси;
  4. dX – среднеквадратические отклонения (степень схождения пересечений) по оси X;
  5. Y – значения по вертикальной оси;
  6. dY – среднеквадратические отклонения (степень схождения пересечений) по оси Y;
  7. Xm – значения "простых средних" по горизонтальной оси;
  8. Ym – значения "простых средних" по вертикальной оси;
  9. nR – число линий равновесий, использованные в расчёте "простых средних";
  10. Scatter – значения "разброса" линий равновесий: корней среднеквадратических расстояний от точек "простых средних" до всех линий равновесий, или RMSD;
  11. Analyses – номера полей и точек анализов (содержимое файла *_REF.TXT);
  12. Комментарии (Comments).

 Вы можете щёлкнуть по заголовку любой из колонок для сортировки таблицы по её значениям. Например, сортировка таблицы по dX или dY позволяет моментально найти диаграммы, демонстрирующие самые лучшие степени схождения пересечений (т.е. для составов минералов, наиболее близких к равновесным с точки зрения используемой термодинамической модели). Кроме того, двойной щелчок по любой из строк позволяет добавить или отредактировать комментарий к диаграмме. Нажмите кнопку Save для сохранения отсортированной таблицы в файл AVG_???.TAB (где ??? зависит от выбранного типа средних значений и, возможно, колонки, по значениям которой отсортированы результаты). TAB-файл является простым текстовым файлом с разделителями – символами табуляции. Эти файлы легко импортируются в программу ©MS Excel.

 Галочки в таблице служат для указания, какие из файлов надо обработать программой INTERSX.EXE в пакетном режиме. Можно также воспользоваться всплывающим меню (правая кнопка мыши) для быстрого выбора групп файлов.

 TWQ_View показывает второе отдельное маленькое окошко Find, если открыто окно Averages. В этом окошке Вы можете выбирать требуемые анализы и таким образом сразу же переходить на нужные комбинации в таблице.

 Программа помещает все комментарии в особый текстовый файл Comments.dat, создаваемый в каталоге с диаграммами.

 При выборе результатов в таблице программа переходит к соответствующей диаграмме.

Plot all/current averages – этот пункт меню переключает режим отображения средних значений: показывать среднее значение только для текущей диаграммы, либо все средние значения (для всех диаграмм, находящихся в рабочем каталоге). При отображении всех средних значений на диаграммах с температурой по горизонтальной оси последние могут показываться разными цветами, соответствующими диапазонам среднеквадратичных отклонений (заданным в переменной dTRanges инициализационного файла TWQ_View.ini). Об использовании разноцветных средних значений см. в разделе "Отображение средних значений (окно Options)".

Simple averages – с помощью этой команды производится вычисление "простых средних" значений для всего набора диаграмм. "Простые средние" можно использовать, как экспресс-метод первичной приблизительной оценки PT параметров (например, при поиске комбинаций анализов, демонстрирующих хорошую сходимость линий реакций) перед запуском программы INTERSX.EXE.

Copy

Copy plot to the clipboard – этот пункт меню просто копирует диаграмму в буфер обмена Windows в виде векторного изображения (в WMF-формате) для последующей вставки в редактор векторной графики (например, ©CorelDraw или ©Adobe Illustrator) или текстовый редактор (например, в ©MS Word).

Save plot as a TVL file – сохранить диаграмму в виде графического файла векторного формата TVL (используемого в программе TriQuick).

Help
 Отображение справочной информации. Пункты подменю:

Help – открыть данный файл справки (TWQ_VIEW.CHM).

About – показать окно с общей информацией о программе и контактной информацией. Вы можете послать мне письмо щелчком по адресу электронной почты (либо просто нажатием клавиши "e" на клавиатуре). Вы также можете нажать кнопку Updates для открытия окна с параметрами автоматической проверки обновлений программы и информацией о её последней версии.

Обратно к Работе с TWQ_View


Диаграмма (главное окно)

 Большая часть свойств диаграммы настраивается в окне Options. Однако, сама диаграмма также интерактивна:

  1. Browsing – используйте две кнопки со стрелками в нижнем правом углу окна (или соответствующие навигационные клавиши со стрелками на клавиатуре) для перехода к предыдущей/следующей диаграмме.
  2. Zooming – используйте левую кнопку мыши для рисования масштабирующего прямоугольника из верхнего левого угла с правый нижний угол требуемой области диаграммы. Изобразите произвольный прямоугольник из любого другого угла для возврата к исходным границам и масштабу.
  3. Scrolling – используйте правую кнопку мыши для навигации "протаскиванием" внутри окна диаграммы (скроллинга).
  4. Clicking – щёлкните по любой из кривых для отображения её уравнения реакции (тут требуется достаточно точное позиционирование, поэтому отображение узлов на кривых может несколько помочь). Щёлкните по кривой или по уравнению правой кнопкой мыши для вызова контекстного меню.

Контекстное меню
 С его помощью можно изменить некоторые параметры выбранной кривой:
  – быстро выбрать линию для сравнения (или отменить её выбор); выбранные линии показываются жирными фиолетовыми (вне зависимости от цветовых установок);
  – цвет;
  – толщину линии (в пределах 1..4 пикселов);
  – символ;
  – скрыть кривую (только в окне с диаграммой).

Допустимые символы
кружок – по умолчанию
прямой крестик
косой крестик
треугольник
перевёрнутый треугольник
квадратик
ромбик
звёздочка
маленькая точка (на самом деле, почти не видна!)


Установки программы (окно Options)

 Большая часть параметров диаграммы настраивается в окне Options, на котором находятся четыре вкладки:

Axes
 На этой вкладке задаются параметры горизонтальной (X) и вертикальной (Y) осей диаграммы. Если галочка Auto установлена, то программа вычисляет минимальное (Minimum) и максимальное (Maximum) значения автоматически, тогда они выделяются жирным шрифтом. В противном случае они по умолчанию берутся из файла с диаграммой. Кроме того, можно задавать и пользовательские границы. Нажмите кнопки Reset для восстановления исходных границ (автоматических или взятых из файла).
 Следующие две величины управляют расстояниями между метками оцифровки осей. Программа использует минимальные дистанции (Minimum increment) вместо жёстко заданных значений, чтобы шаг оцифровки оставался приемлемым при изменениях размеров окна и масштабировании диаграммы. В некоторых случаях удобно задавать большие значения. Однако, лучшим решением может оказаться установка подходящего значения параметра Separation – доли (в %) от минимальной дистанции между метками (в диапазоне 10..255). Видимость меток также зависит и от размера их шрифта.

Colors
 Все цвета, которые используются для линий реакций, показываются в списке Curves разноцветными строчками со значениями цветов в виде целых 16-ричных чисел с префиксом "#", представляющих триплет RGB. Если из файла TWQ_View.ini удалить все строчки переменной Color=, то программа при запуске заполняет этот список 16-ю значениями по умолчанию (используемыми программой TWQ):

  1. Чёрный
  2. Синий
  3. Зелёный
  4. Голубой
  5. Красный
  6. Фиолетовый (фуксия)
  7. Коричневый
  8. Серый
  9. Тёмно-серый
  10. Светло-синий
  11. Светло-зелёный
  12. Светло-голубой
  13. Светло-красный (розовый)
  14. Светло-фиолетовый (св. фуксия)
  15. Жёлтый
  16. Белый

NB! Стандартные цвета включают чёрный (первый) и белый (последний) – скорее всего, потребуется заменить один из них, чтобы линии были видны и отличались от фона! В остальных случаях программа не позволяет выбирать цвет линий, совпадающий с цветом фона (и наоборот).
 Щелчком правой кнопкой мыши по списку цветов вызывается небольшое контекстное меню для некоторых операций со цветами: пункт Add добавляет новый цвет в конец списка (то же самое можно сделать двойным щелчком по пустой области в его конце), Insert вставляет новый цвет в текущую позицию (то же самое делается кнопкой <Insert> на клавиатуре), Delete удаляет выбранный цвет (это же делается кнопкой <Delete> на клавиатуре; по крайней мере, один цвет должен присутствовать), Edit для изменения выбранного цвета. Выбранный цвет можно также изменить двойным щелчком по нему мышью. Наконец, порядок цветов можно изменять перетаскиванием мышью.
 Поставьте галочку Auto для автоматического назначения цветов. Порядок цветов определяется их порядком в списке, порядок кривых – их следованием в файле диаграммы. Программа использует цвета, определённые в файле диаграммы, только если эта галочка снята.
 Можно также определять цвета для отдельных линий непосредственно в окне с диаграммой с помощью их контекстного меню.

 Для определения других цветов на диаграмме используются кнопки: Fill – устанавливает цвет фона, Pen – устанавливает цвет осей и их подписей, Grid – смена цвета линий сетки (его стоит делать близким к цвету фона).

 Кнопка Averages служит для настройки СКО-диапазонов средних значений по оси температуры, отображаемых разными цветами на P-T диаграммах в режиме показа всех результатов. При её нажатии открывается небольшое окно Avg colors с текущим списком диапазонов. Цветные средние значения показываются при установленной там галочке Use colored MSD ranges. В самом списке можно устанавливать/снимать галочки для конкретных диапазонов, чтобы показывать/скрывать соответствующие результаты. Перед добавлением диапазона (кнопка Add) или его редактированием (кнопка Edit) надо установить требуемое целое значение СКО по температуре в поле для редактирования. Кнопка Delete удаляет выбранный диапазон.

Averages
 Используйте галочку Show в верхней части этой вкладки для отображения/скрытия всех типов средних значений на диаграмме. Опция Ranged включает/выключает отображение разными цветами распределения средних значений по диапазонам СКО и в соответствии со значениями разброса линий Scatter (для "простых средних"). При установленной галочке в углах диаграммы показываются дополнительные легенды. Если выбрана опция B/W, то вместо полноцветных палитр для отображения средних используются градации серого (что может пригодиться для печати или в публикациях). Вы также можете при желании использовать обратный порядок цветов для точек на диаграммах, установив галочку Inversed.

TWQ: средние значения TWQ
 Они представлены точками, крестами или эллипсами, чьи размеры отвечают величинам среднеквадратических отклонений (в зависимости от установки опций + и O). Кроме того, можно управлять выводом различных типов средних значений соответствующими им галочками:

  1. All – значения, основанные на всех пересечениях,
  2. 1.5s – значения, основанные на пересечениях, лежащих в пределах 1.5 величин среднеквадратического отклонения,
  3. IR – значения, основанные на пересечениях некоторого(?) набора линейно независимых равновесий.

Их цвета берутся из общего списка для линий равновесий, описанного выше. Установкой параметра Size задаётся размер точек (от 3 до 15), галочки Outline – показ контура точек или эллипсов.

Simple: "простые средние"
 Опции Show, Size и Outline аналогичны таковым для средних значений TWQ (см. выше).

Parameters
 Для некоторых видов диаграмм можно производить преобразование используемых на них единиц: поставьте галочку bar → kbar для использования традиционных кбар вместо бар, используемых в файлах диаграмм, галочку Log(α) → α – для построения диаграммы с активностями вместо их логарифмов.
 Опция Numerate включает нумерацию линий равновесий. Номера ставятся на второй или предпоследний узел, попадающий в поле диаграммы и могут оказаться невидимыми, только если все узлы кривой находятся за границами диаграммы. Вы можете также заметить, что TWQ строит линии, начиная с максимальных значений по осям (что будет выглядеть, как появление нечётных номеров в верхней правой области диаграммы и чётных – в нижней левой области).

 Некоторые узлы на линиях равновесий в файлах диаграмм TWQ лежат очень близко друг к другу (из-за особенностей алгоритма TWQ). Это может приводить к дополнительным артефактам на экспортируемой WMF-графике (выглядящим, как короткие сильно искривлённые участки). Следовательно, хорошим решением оказывается удаление лишних узлов с диаграммы. Отметьте галочкой опцию Remove close nodes, чтобы "чистить" таким образом линии при загрузке файлов. Эта процедура использует единственный настраиваемый параметр: минимальную дистанцию между узлами. Эта величина зависит от диапазона значений по оси, поэтому используется параметр Div = диапазон оси / минимальная дистанция между узлами. В большинстве случаев годятся значения около 30-50.

Show
 Используйте эти три галочки для отображения/скрытия разных элементов диаграммы: Legend – легенды, Major grid – основных линий сетки, Minor grid – промежуточных линий сетки.

 Last dirs – максимальное число каталогов, отображаемых в конце меню File). Допустимые значения лежат в пределах 3..30.

 Titles – размер шрифта заголовков осей, Labels – размер шрифта для оцифровки осей, Lines width – ширина линий и осей (в диапазоне 1..4 пиксела). Ширину отдельных линий также можно установить непосредственно в окне диаграммы с помощью их контекстного меню.


Списки равновесий и компонентов (окно Equilibria)

 Это окно предоставляет доступ к отдельным равновесиям по их уравнениям и участвующим в них компонентам. С его помощью, например, можно перемещаться по списку файлов диаграмм и просматривать положение только некоторых выбранных равновесий.

 Пронумерованные уравнения находятся в списке в левой части окна. Перед номерами уравнений ставится номер диаграммы, если отображается комбинация из нескольких диаграмм. Вы можете использовать галочки, расположенные перед каждым уравнением, чтобы отображать или скрывать отдельные линии (их можно ставить мышью либо клавишей <Insert> на клавиатуре). Двойной щелчок по уравнению (или нажатие клавиши <Enter>) переключает режим отображения узлов на линиях. Символ для узлов по умолчанию – кружок. Однако, Вы можете выбрать другой символ и остальные параметры для индивидуальных линий с помощью контекстного меню:

  1. Select – быстро выбрать линию для сравнения (или отменить её выбор); выбранные линии показываются жирными фиолетовыми (вне зависимости от цветовых установок);
  2. Change color – сменить цвет выбранной линии;
  3. Change width – сменить толщину выбранной линии (в пределах 1...4);
  4. Change symbol – сменить символ для узлов выбранной линии;
    Допустимые символы
    кружок – по умолчанию
    прямой крестик
    косой крестик
    треугольник
    перевёрнутый треугольник
    квадратик
    ромбик
    звёздочка
    маленькая точка (на самом деле, почти не видна!)
  5. Save to a text file – сохранить список равновесий...
    • This plot – ...текущей диаграммы в файл EQ_???.TXT, где ??? – имя TWQ-файла;
    • All plots – ...из всех перечисленных в списке TWQ-файлов в файл EQ_ALL.TXT.
  6. Save TWQ file as... – сохранить текущий файл TWQ (с диаграммой) в новый файл, содержащий только отмеченные галочками равновесия.
 Используйте кнопки Show all и Hide all для отображения/скрытия всех линий равновесий, кнопку Invert – для показа скрытых линий и скрытия отображаемых. Кнопки Show nodes и Hide nodes служат для показа/скрытия узлов на каждой видимой линии.

 С помощью списка list of components можно скрывать линии равновесий, содержащих определённые компоненты. Например, снятие галочек для кромпонентов A и B (мышью или клавишей <Insert>) скроет все равновесия с их участием, а последующее нажатие кнопки Invert покажет только те равновесия, в которых они участвуют. Двойной щелчок по компоненту (либо нажатие клавиши <Enter>) скроет все равновесия, в которых данный компонент не участвует (что равносильно снятию галочки для него с последующим нажатием кнопки Invert). Расстановка галочек в этом списке меняется при нажатиях кнопок Show all, Hide all и Invert, равно как и при установке галочек в списке уравнений.

 Если какие-то линии равновесий не показываются, то при использовании программы INTERSX.EXE средние параметры будут вычисляться только с учётом отображаемых линий. Это удобно для исключения линий, слишком сильно меняющих своё положение при совсем незначительных вариациях составов минералов.


Список диаграмм (окно Plot-files)

 В окне Plot-files находятся два списка:

Список файлов с диаграммами
 Программа заполняет этот список имнами файлов с диаграммами, найденных в текущем рабочем каталоге (для смены каталога надо загрузить какой-нибудь файл из другого места с помощью меню). При перемещениях по списку программа сразу же отображает соответствующие диаграммы.

 Информация из текущего файла и рассчитанные средние значения (если они существуют) показываются в поле, расположенном в центре окна. Программа может также показывать в нём данные файлов составов (если они присутствуют) при установленной галочке Show CMP. Имена файлов составов берутся из информации, находящейся в файлах с диаграммами. Программа игнорирует указанные там пути и пытается загружать файлы составов только из рабочего каталога с файлами диаграмм.

 Перед блоками с информацией ставятся номера диаграмм, если отображаются комбинации из нескольких файлов. Вы можете редактировать этот информационный текст и скопировать его в буфер Windows (например, вместе с WMF-графикой).

 Отметьте галочкой пункт Combine для комбинирования диаграмм, последовательно загружаемых при навигации по списку файлов. При этом их информационные блоки будут накапливаться в текстовом поле. В комбинации допускается совмещение не более 255 диаграмм.

 Программа использует последние использовавшиеся параметры линий равновесий (установленные в окне с диаграммой и в списке равновесий) при загрузке новых файлов с диаграммами.

 Нажмите кнопку Refresh для обновления списка файлов (например, если Вы рассчитали и добавили новые файлы при работающей программе TWQ_View, либо если Вы хотите восстановить исходный масштаб диаграммы составов).

Список расширений (типов) файлов "Types"
 Используйте этот список для добавления и удаления используемых в TWQ расширений (типов) файлов с диаграммами. При нажатии на правую кнопку мыши в списке показывается маленькое контекстное меню: выберите в нём Add (либо произведите двойной щелчок мышью по расширению в списке) для добавления новго типа, Delete) – для удаления выбранного расширения. Кроме того, отдельные типы можно временно выключать с помощью галочек перед ними (что может оказаться полезным для просмотра только результатов вычислений, выполненных в пакетном режиме TWQ). Все эти действия приводят к обновлению списка файлов.


Диаграмма составов (окно CMP-files)

 Эта диаграмма является альтернативой P-файлам, создаваемым программой CMP.EXE пакета TWQ.

 TWQ_View ищет файлы с составами минералов (например, CMP-файлы DOS-версий TWQ) в рабочем каталоге, используя список файлов с диаграммами окна Plot-files. Программа перестраивает эту диаграмму при каждом обновлении этого списка. Собственно имена файлов составов берутся из файлов с диаграммами. Программа игнорирует указанные там пути и всегда ищет нужные файлы только в рабочем каталоге с диаграммами. Каждая строка в списке файлов диаграмм имеет соответствующую колонку на диаграмме составов, подписанную именем файла с составами. Если некоторые из подписанных колонок пустые, то это означает, что файл составов предполагается, но отсутствует в рабочем каталоге.

 Окно состоит из двух частей:

Диаграмма
 Вы можете масштабировать и перемещать содержимое этого графика, как и для основной диаграммы с линиями равновесий (однако, доступно перемещение только в горизонтальном направлении). Программа использует для линий цвета, определённые в окне Options, либо стандартные 16 цветов:

  1. Чёрный
  2. Синий
  3. Зелёный
  4. Голубой
  5. Красный
  6. Фиолетовый (фуксия)
  7. Коричневый
  8. Серый
  9. Тёмно-серый
  10. Светло-синий
  11. Светло-зелёный
  12. Светло-голубой
  13. Светло-красный (розовый)
  14. Светло-фиолетовый (св. фуксия)
  15. Жёлтый
  16. Белый

 Символы для точек берутся из списка, указанного для окна с главной диаграммой. Программа выделяет жёлтыми полосками колонки файлов составов, соответствующих текущим загруженным файлам диаграмм.

Списки фаз и их переменных
 В этих двух списках можно галочками выбирать фазы и переменные их составов (мольные доли компонентов или элементов), которые должны отображаться на графике. Программа запоминает неиспользуемые переменные (со снятыми галочками) в файле TWQ_View.ini. Таким образом Вы можете определить постоянный набор наиболее информативных переменных для каждой из фаз. Манипуляции с целыми фазами (в левом списке) на этот набор влияния не оказывают.

 Программа удаляет квадратные скобки и дефисы (-) из имён переменных, обнаруженных в шапках файлов составов TWQ. Вы можете использовать и свои собственные, более традиционные имена для фаз и их переменных: для этого надо редактировать специальный текстовый файл с заменами аббревиатур.

 Под списками находятся три кнопки. Нажмите кнопку Save X-scale после масштабирования графика для сохранения текущего горизонтального масштаба. Программа будет использовать это значение при последующих запусках (вместо автоматически определяемого горизонтального масштаба). Нажмите кнопку Auto X-scale для масштабирования линий по ширине диаграммы (Вы можете восстановить выбранный вручную масштаб обновлением списка файлов с диаграммами нажатием кнопки Refresh в окне Plot-files). Кнопка Reset colors служит для переопределения цветов и символов с учётом исключённых переменных состава.


Файл с заменами аббревиатур (TWQ_VIEW.RPL)

 Надо заметить, что многие аббревиатуры минералов, используемые в пакете TWQ, не являются общепринятыми, а некоторые даже оказываются некорректными (например, абрревиатура для силлиманита такая же, как обозначение химического элемента кремния – "Si"). С помощью программы TWQ_View Вы можете автоматически заменять такие аббревиатуры на диаграммах и в различных списках на более привычные: для этого надо лишь отредактировать простой текстовый файл TWQ_VIEW.RPL. Этот файл находится в основном каталоге программы. Он содержит только список замен для аббревиатур веществ и переменных их составов. Каждая строчка в TWQ_VIEW.RPL имеет простой формат:

n абрревиатура_TWQ=Новая аббревиатура

где n является кодом переменной: 1 – название твёрдого раствора, 2 – название компонента фазы (чистого вещества), 3 - переменная состава.
 Длина новой аббревиатуры не может быть больше 6 символов. После редактирования этого файла надо также синхронизировать с ним переменные, находящиеся в конце инициализационного файла (TWQ_VIEW.INI)


Переменные инициализационного файла (TWQ_VIEW.INI)

 В большинстве случаев редактировать этот файл нет никакой необходимости.
Переменная | Описание
PlotPath | Рабочий каталог с файлами диаграмм, экземпляров переменной может быть много
LastDirs | Количество последних использовавшихся рабочих каталогов (для меню)
Repository | Каталог-хранилище для часто используемых диаграмм-шаблонов
PathLength | Максимальная длина пути (к каталогу TWQ и к файлам диаграмм), обычно 20.
TWQDir | Путь к файлам DOS-версии пакета TWQ
DOSBox | Каталог, в котором находится исполняемый файл DOSBox.exe (при установленном эмуляторе)
ForceDB | Всегда использовать эмулятор DOSBox. Допустимые значения: "Y", "y", "1" – да; "N", "n", "0" – нет
TDB | Определение (название) базы термодинамических данных, таких определений может быть много
SLN | Имя SLN-файла (с моделями твёрдых растворов), связанного с текущей TDB
CurrentTDB | Индекс текущей БД
TWQPaused | Yes – не закрывать DOS-окно после завершения программы INTERSX.EXE
ShowAVG | Yes – отображать средние значения на диаграмме
xAll | Yes – отображать средние значения, основанные на пересечениях всех линий
x15s | Yes – отображать средние значения, основанные на пересечениях в пределах 1.5 сигмы
xIR | Yes – отображать средние значения, основанные на пересечениях набора линейно независимых равновесий
xCross | Yes – отображать средние значения крестами (с величинами СКО), No – отображать средние значения точками (или эллипсами)
xEllipse | Yes – отображать средние значения эллипсами (с величинами СКО), No – отображать средние значения точками (или крестами)
Extension | Расширение (тип) файла с диаграммой, экземпляров переменной может быть много
AutoColor | Yes – назначать цвета автоматически
Color | Цвет линии (целое число, представляющее триплет RGB), экземпляров переменной может быть много
FillColor | Цвет фона
PenColor | Цвет осей и их оцифровки
GridColor | Цвет линий сетки
MajorGrid | Yes – отображать основные линии сетки
MinorGrid | Yes – отображать промежуточные линии сетки
TitlesSize | Размер шрифта заголовка
LabelsSize | Размер шрифта меток оцифровки осей
ShowLegend | Yes – отображать легенду
AutoAxes | Yes – вычислять масштабы осей автоматически
CleanClose | Yes – удалять слишком близко расположенные узлы на линиях равновесий
MinDistDiv | Параметр Div = диапазон осей / минимальное расстояние между узлами
LinesWidth | Ширина линий (в т.ч. линий равновесий по умолчанию)
Bar2kbar | Yes – использовать кбары вместо бар
Log2a | Yes – использовать активности вместо логарифмов активностей
LabelSepX | Горизонтальное разделение меток оцифровки осей (%)
LabelSepY | Вертикальное разделение меток оцифровки осей (%)
Numerate | Yes – нумеровать линии
AddCMP | Yes – добавлять данные из CMP-файлов на панель информации
CMPScale | Масштаб горизонтальной оси на графиках составов (0 – автоматический)
dTRanges | Определения цветов для средних значений с разными стандартными отклонениями (СКО) на диаграммах с температурой по горизонтальной оси, пары граничных значений СКО для температуры (целые числа) и соответствующих цветов, разделённые пробелами
ColoredAvg | Yes – отображать на P-T диаграммах средние значения разными цветами (если показываются все результаты)
WtSmpAvg | Yes – использовать взвешенные расстояния при вычислении "простых средних" значений
AvgSize | Размер точек средних значений (целое число от 3 до 15)
AvgOut | Yes – отображать точки средних значений с чёрными контурами
SmpAvgSize | Размер точек "простых средних" значений (целое число от 3 до 15)
SmpAvgOut | Yes – отображать точки "простых средних" значений с чёрными контурами
AvgBW | Yes – использовать градации серого вместо полноцветных палитр при отображении средних значений
ChkUpdates | Yes – производить автоматические проверки обновлений программы
CUPeriod | Периодичность авто-проверок обновлений (0 – ежедневно, 1 – раз в неделю, 2 – раз в месяц)
LastUpdate | Дата и время последней проверки обновлений
Desktop | Название для сохранённого набора параметров окон программы (размеров и расположения):
ShowEquil | Yes – показывать окно "Equilibria" при старте программы
ShowFiles | Yes – показывать окно "Plot-files" при старте программы
ShowCMP | Yes – показывать окно "CMP-files" при старте программы
ShowOpt | Yes – показывать окно "Options" при старте программы
MainTop | Главное окно – координата верхней границы
MainLeft | Главное окно – координата левой границы
MainHeight | Главное окно – высота
MainWidth | Главное окно – ширина
FileTop | Окно "Plot-files" – координата верхней границы
FileLeft | Окно "Plot-files" – координата левой границы
FileHeight | Окно "Plot-files" – высота
FileWidth | Окно "Plot-files" – ширина
OptTop | Окно "Options" – координата верхней границы
OptLeft | Окно "Options" – координата левой границы
EquTop | Окно "Equilibria" – координата верхней границы
EquLeft | Окно "Equilibria" – координата левой границы
EquHeight | Окно "Equilibria" – высота
EquWidth | Окно "Equilibria" – ширина
CMPTop | Окно "CMP-files" – координата верхней границы
CMPLeft | Окно "CMP-files" – координата левой границы
CMPHeight | Окно "CMP-files" – высота
CMPWidth | Окно "CMP-files" – ширина
AvgTop | Окно "Averages" – координата верхней границы
AvgLeft | Окно "Averages" – координата левой границы
AvgHeight | Окно "Averages" – высота
AvgWidth | Окно "Averages" – ширина
FindTop | Окно "Find" – координата верхней границы
FindLeft | Окно "Find" – координата левой границы
Phase | Определение фазы (аббревиатура), таких определений может быть много. Вы должны проверять (и исправлять при необходимости) эти аббревиатуры, если они были заменены в файле TWQ_VIEW.RPL.
Cfc | Определение переменной состава (название коэффициента) для текущей фазы и её отображение на графике составов, таких определений может быть много. Вы должны проверять (и исправлять при необходимости) эти аббревиатуры, если они были заменены в файле TWQ_VIEW.RPL.


Ограничения и проблемы

 Ограничения в TWQ_View:

  1. Из меню программы можно запускать только старую DOS-версию программы INTERSX.EXE (что особенно важно для вычислений в пакетном режиме). Однако, программа может оперировать результатами, полученными и с помощью Windows-версий пакета TWQ.
  2. В уравнениях реакций используются только короткие аббревиатуры (длиной до 6 символов), полные имена компонентов невозможны.
  3. Файлы с диаграммами, файлы составов и со средними значениями должны находиться в одном каталоге.
  4. В путях и именах файлов не допускаются национальные буквы, в т.ч. русские (т.е. буквы могут быть только латинскими).
  5. Длины путей к пакету TWQ и рабочим файлам (вместе с завершающей обратной косой чертой "\") не должны быть больше 20 символов, это ограничение TWQ. Однако, это ограничение (равно как и запрет на длинные имена каталогов) снимается при использовании эмулятора DOSBox.
  6. Линии на диаграммах не подписываются уравнениями реакций, т.к. реализовать это корректно и эстетично при наличии большого количества линий крайне сложно. Таким образом, можно либо подписывать линии вручную в векторном графическом редакторе, либо использовать автоматическую нумерацию линий.
  7. Если применяется преобразование Log(α)→α, то в информации о диаграмме показывается только одно значение среднеквадратического отклонения (по другой оси). Однако, крест на диаграмме должен строиться корректно.

 В TWQ_View обнаружены следующие некритические проблемы:

  1. Иногда границы диаграммы незначительно скачут после их редактирования в окне Options (введите значения заново или нажмите кнопку Reset в окне Options для исправления);
  2. Иногда восстановление масштаба диаграммы с помощью мыши работает неверно (введите значения заново или нажмите кнопку Reset в окне Options для исправления);
  3. При целочисленных значениях границ по оси X (например, при xCO2=0.00–1.00 на соответствующих диаграммах) подписи оцифровки располагаются слишком тесно и перекрывают друг друга. Я попытался решить эту проблему добавлением/вычитанием очень малой величины 0.00001 к значениям границ.
  4. Линии на диаграммах могут вести себя очень странно (исчезать или двоиться) при слишком большом масштабе: избегайте чрезмерных увеличений!
  5. Теоретически, линии нескольких линейно независимых равновесий должны пересекаться в одной точке. Однако, на увеличенных диаграммах они оказываются заметно разошедшимися из-за того, что программы TWQ и TWQ_View аппроксимируют кривые с помощью ломаных, т.е. прямолинейными сегментами между узлами, вычисленными в TWQ. Кроме того, может сказываться и точность вычислений положения узлов.
  6. Программа не поддерживает команды "pen up" и "pen down", используемые в файлах диаграмм: TWQ_View всегда соединяет отдельные фрагменты линий отрезками (например, если кривая обрезана границами окна в двух местах).
  7. Проблемы в экспортированной WMF-графике:
    1. Риски вертикальной оси немного смещены влево.
    2. Вследствие низкой (экранной) точности координат, присущей WMF-графике, линии и другие объекты могут искажаться, что становится заметным при больших увеличениях. Расширение окна с диаграммой частично решает эту проблему.


Ссылки

Основная публикация по TWQ:
Berman R.G., 1991. Thermobarometry using multiequilibrium calculations: a new technique with petrologic applications. Canadian Mineralogist, v. 29, pp. 833-855.

Интернет:
сайт TWQ


Простые средние

 "Простые средние" ("simple averages") – это точки кратчайших среднеквадратичных расстояний (или RMSD) до всех линий реакций:

 "Простые средние" близки к средним величинам, вычисляемым программой INTERSX (или winTERSX) из комплекса TWQ Р. Бермана, Т. Брауна, Э. Перкинса и Дж. Эллвуда. Однако, у них есть некоторые важные отличия:

  1. "Простые средние" основаны на полностью геометрических построениях без привлечения термодинамики, тогда как программа INTERSX вычисляет средние значения по точкам пересечения линий, взвешенным в соответствии с модифицированными константами равновесия реакций, их энтропийным и объёмным эффектам (а также углам между линиями). NB! Игнорирование термодинамических параметров делает "простые средние" менее корректными, особенно если линии реакций образуют плохо сходящийся "пучок". Поэтому "простые средние" стоит использовать лишь как экспресс-метод первичной приблизительной оценки PT параметров (например, при поиске комбинаций анализов, демонстрирующих хорошую сходимость линий реакций).

  2. Определение "простых средних" включает вычисление расстояний на плоскости XY, поэтому он использует масштабирование осей и даёт в итоге единственную величину RMSD (которую следует считать безразмерной). Хотя программа INTERSX вычисляет две различных величины среднеквадратических отклонений по двум осям, в ней также производится масштабирование осей: например, при вычислении углов пересечения линий реакций (для отбраковки пересечений и расчёта их весов). Скорее всего, масштабирование осей в INTERSX зависит от заданных пользователем диапазонов осей (что можно обнаружить по небольшим отличиям результатов), тогда как для "простых средних" применяется фиксированный (специально задаваемый пользователем) масштабирующий коэффициент, позволяющий непосредственно сравнивать величины RMSD для диаграмм с различными диапазонами осей. Скажем, Вы можете выбрать постоянный множитель "50" для оси "P, кбар", чтобы получить сходный порядок величин по обеим осям на типичных PT диаграммах, используемых для коровых условий метаморфизма (например, 400-900°C и 1-11 кбар). Этот множитель можно обосновать и более строго:

    • деление величин T и P на средние (типичные) величины погрешностей их определения (скажем, 20° и 0.4 кбар для коровых пород) даёт безразмерные оси с таким же отношением величин;

    • отношения стандартных объёмов V0f(Дж/бар) к энтропий S0f(Дж/K) (участвующих в выражении ΔG=ΔH-T×ΔS+(P-1)×ΔV) для большинства минералов обладают тем же порядком величин 0.004-0.006 (или ≈50 после перевода в килобары).

  3. Минимизация функции расстояний до линий реакций, используемая для "простых средних", даёт более стабильные результаты, нежели усреднение точек пересечения. В частности, программа производит линейную экстраполяцию линий реакций за пределы XY окна, если это необходимо. Величины RMSD просты в вычислении, их функция является строго выпуклой (в подавляющем большинстве случаев) с минимумом, быстро находящимся любыми классическими алгоритмами: